
KiCad Hierarchy Tutorial x01

This is an early draft of a tutorial, introducing how to use KiCad to draw hierarchical schematics.  This 
tutorial is still in the writing phase.  Your comments will be appreciated.

Jonathan Hill, August 2, 2010
jmhill at hartford dot edu

This tutorial uses an example to introduces how to use the hierarchy capabilities with KiCad.
• This tutorial corresponds to KiCad version 2010-05-05
• I am using 32 bit Windows Vista
• I am right handed and use a right handed mouse
• You should know basic operations involving your operating system, such as selecting files and 

navigating folders or directories using point and click techniques
• You should have an idea how to use KiCad how to draw a simple one page schematic
• This tutorial also includes topics related to simple TTL circuits

The example uses hierarchy to make a ripple carry adder for a pair of three bit binary values.

Create a New Project
First, create a new project.  In the KiCad project window use the mouse to select the following

File => New

I am using a memory stick that has been mounted as the E: drive on my laptop computer.  With regards 
to disk accesses, KiCad is fairly light and it works well having a project stored on a memory stick.  At 
one time KiCad required the name of the project folder to be the same as the project file that it 
contains.  Regardless, we will stick with tradition and name the project file and project folder with the 
same base name.

In the 'Create new Project' pop-up window, navigate and click the 'New Folder' as necessary.  I created 
a folder named 'KiCad', which contains a folder named 'add3'.  Navigate inside the add3 folder and in 
the 'File name field', enter the name 'add3.pro' and click 'Save'.  The following path should now be 
visible in the title bar:

E:\KiCad\add3\add3.pro

Create the Root Schematic
In the KiCad project manager window, left click the EESchema icon to start the schematic capture tool. 
To cause the pop-up hint to appear for an icon, float the cursur over a button.

'EESchema' icon

The schematic capture tool will open and the 'Info' pop-up window will produce the following report:



'File <E:\KiCad\add3\add3.sch> not found'

Left click 'OK'.  Note that KiCad has already named the new schematic add3.sch.  This schematic is 
also referred to as the 'root' schematic as it will represent the top of the hierarchy.  Next, it is a good 
idea to set the page size.  Click the Page Settings icon

'Page Settings' icon

In the 'Page Settings' popup window, the 'Size A' is a good choice for smallish schematics like that for 
this project.  In the 'Title' field enter 'Adder circuit' and in the 'Company' field enter your name.  Click 
to select the 'Export to other sheets' buttons and then click OK.

Place a Hierarchical Sheet Symbol Before Drawing the Underlying Schematic

Left click to select the following in the schematic capture window:

File => Save Whole Schematic Project

Next, place a hierarchy sheet.  Either click the 'Place hierarchical sheet' icon or click to make the 
following selection:

Place => Hierarchical sheet

'Place hierarchical sheet' icon

In the schematic capture window area, just click left, that is press and depress the left mouse button to 
start placing the hierarchical sheet.  Moving the mouse will scale the size of the box that represents the 
sheet.  Move the mouse so the box is roughly one inch wide by three quarters of an inch tall and left 
click, so the 'Schematic Sheet Properties' pop-up window appears.  Enter 'fadd1.sch' as the 'File name' 
and 'fadd1' as the 'Sheet name' and then click 'OK' then press the escape key on your keyboard to return 
to the normal pointing mode.

Schematic Sheet Properties pop-up window

Next, zoom toward the new sheet symbol.  To zoom in and out you have some choices:



Zoom In (+) and Zoom Out (-) icons

• Click the Zoom in and Zoom out icons
• Select View=>Zoom In, or View => Zoom Out
• Pressing the F1 and F2 function keys zoom in and out, respectively
• If you have a wheel mouse, the middle wheel will cause the view to zoom in and out

Here we will add pins to the sheet symbol to produce the sheet symbol shown below and then draw the 
corresponding schematic.  In a later example we will use a different technique that is based on an 
existing schematic.

Sheet symbol for fadd1

Either click left to select the following, or click left on the 'Place hierarchical pin' icon, move the cursor 
into the sheet symbol, and click left so the 'Pin Sheet Properties' window pops up.

Place => Add Hierarchical Pin to Sheet

'Place a hierarchical pin' icon

Enter 'Ci' into the 'Text:' field and click the 'Input' button, then click 'OK', then position the new pin to 
the upper left of the sheet symbol.  Likewise, insert input pins for 'A' and 'B' as well as output pins for 
'S' and 'Co' as shown above.  



Insert Components

Press the escape key to return to the normal point and select mode.  To open the new corresponding 
schematic for fadd1, double click in the fadd1 sheet symbol.  With the schematic open, adjust the page 
size as you did before.  We will place components, insert wires, and complete the schematic for fadd1. 
In the following you will insert gates in a manner like the the following figure.

Full adder components

To insert these components, start by clicking the 'Place a component' icon or make the corresponding 
selection, move the cursor into the schematic are and click left.

Place => Component

'Place a component' icon

In the 'component selection' window, click 'Select by Browser'.  In the 'Library Browser' left pane, click 
to select '74xx' and in the middle pane, move the slider to find and click '74LS00'.  The outline of a 
NAND gate will appear in the right pane.  Click the 'Insert component in schematic' icon.

'Insert component' icon

In the schematic, left click the mouse to place the component.  At this point the component designators 
have not yet been defined and the gates have similar pin numbers.  We will address this soon.

Move Components

Move the cursor into the schematic area and click left to place the component.  Open the 'component 
selection' window as before, but this time in the 'History list:' field, click to select '74LS00' and in the 
schematic place a second and a third 74LS00 gate.  Next, place a 74LS10 gate and two 74LS86 gates. 
Thus far, the schematic should look similar to the figure above.

To move one or more components about, there are several options
• Point at a line in a component shape and press the 'M' key to grasp the component, move the 

mouse, then left click to place the component



• Point at a line in a component shape and then right click, and in the pop-up menu, select the 
corresponding move command to grasp the component, then left click to place component

• To move one or more components, you can grasp the components in a block.  Imagine a box 
about the components.  Move the cursor to one corner of the box and press the left mouse 
button, next drag the mouse to the opposite box corner, and then release.  Now the selected 
component move with the cursor.  Left click to place the components.

Grasping components in a block in that fashion makes provides many options to perform what are 
called block commands.  To start, once the components are grasped, right click to perform a block 
command.  We will investigate component dragging later.

Placing Wires

In the following you will place wires so the schematic will look like the following:

Gates and wires

To place a wire, it is necessary to enter the 'Wiring Mode'.
• With the mouse, select Place => Wire, next position the cursor in the schematic and and left 

click to start placing a wire.
• With the mouse, click the 'Place Wire' icon and then left click to start placing a wire

'Place Wire' icon

• Point the cursor at a point in the schematic and press the 'W' key.  Unlike the others, this method 
also starts the actual placement of a wire.

The wire mode inserts horizontal or vertical wire segments.  With a wire started, left clicking in space 
places a wire bend, but left clicking another wire or a component terminal ends the wire.  To end a wire 
in space, either double click, or right click and in the pop-up menu select, 'End Wire'.  Right clicking 
and selecting 'Cancel' prevents the new wire from being inserted in the schematic.



Hierarchical Label

With hierarchical labels the schematic will look like the following:

Components, wires, and labels

The hierarchical pins in a sheet symbol correspond to the hierarchical labels in a schematic.  Either 
click the icon or make the following selection:

Place => Hierarchical Label

 'Place Hierarchical Label' icon

Move the cursor into the schematic area and left click.  In the pop-up window enter the following:
• In the Text field, enter 'Ci'
• In the Size field change the value to 0.120
• In the Style field, click 'Normal'
• In the Orientation field, click 'Right'
• In the Shape field, click 'Input'

Click OK, position the cursor at the upper left wire end and then left click to place the label.  Repeat 
the above steps to place labels for 'A' and 'B'.  The 'S' and 'Co labels are outputs, make the following 
adjustment to the above steps

• In the Orientation field, click 'Left'
• In the Shape field, click 'Output'



Local Labels

Finally, we can insert labels into a schematic.  This makes it easier during a simulation to identify the 
signals present in the schematic.  The schematic will look like the following:

Components and all labels

Click the icon or make the following selection

Place => Label

'Place net name' icon

Left click in the schematic area and in the pop-up window and enter:
• In the Text field, enter 'X'
• In the Size field, enter 0.120
• In the Orientation field, click 'Right'
• In the Style field click 'Normal'

Click OK

Move the cursor to point at upper middle wire as in the figure above and left click to place the label. 
Repeat the process above to place the Y and Z labels.  Press the escape key to exit this tool and return 
to the normal mode, and then:

File => Save Entire Schematic Project



Hidden Pins, Power, and Global Networks

Some components, such as the logic gates the this schematic have hidden pins for power and ground. 
To identify these pins, do either of the following:

• Click the 'Show Hidden Pins' icon

Show Hidden Pins icon

• With the mouse, select Preferences => Options and in the pop-up window click the 'Show 
hidden pins' button then click OK

Zoom in closer to examine the hidden pins, using the techniques described earlier.  Networks in a 
schematic having the same name are normally connected together.  These particular hidden pins are 
attached to a global network for all the pages in your project, however KiCad is not aware of the 
significance of these particular global networks.  Make a note that the power and ground networks are 
named VCC and GND.  To hide the pins use the steps above to no longer display the hidden pins.

The rules checker needs to be informed of the significance of such networks.  There are at least two 
approaches:

• Use the library editor to create or modify a connector, to indicate that certain pins are of type 
power in, and connect the ground and power network, each to such a pin.  Such a pin indicates 
that the networks will be driven externally.

• Use flags to indicate  that the networks be driven with a power supply.  In the following, we use 
the flags approach.

Move back to the root schematic by moving the cursor into the schematic, right click and select 'Leave 
Sheet'.  The following steps outline how to insert two PWR_FLAG components so that you can attach 
two bent wires, and two global labels to like the following:

Power Flags

Insert the PWR_FLAG components and wires as described above.  To place the global labels, either 
click the icon or with the mouse select

Place => Global label

'Place Global Label' icon

Next, in the schematic area, left click and in the pop-up window enter:



• In the Text field enter VCC
• In the Size field enter a size, 0.100 or 0.120 is good
• In the Orientation field click 'Left'
• In the Style field click 'Normal'
• In the Shape field click 'Passive'

Press the escape key to exit this tool and return to the normal mode, and then:

File => Save Entire Schematic Project

Component designators are an issue in a hierarchical design as each component must have its own 
unique designator.  Component designators may be set manually or may be set by the KiCad tool.  

Input-Output Pins

The KiCad rules checker needs to have the inputs driven in a schematic, and a place for the output to 
go.   The schematic for the full-adder uses hierarchical labels that connect to pins in the higher level 
schematic.  The top-level schematic should not use such hierarchical labels as this is the top-level. 
There are at least two approaches.

• Insert symbols such as signal generators and power supplies.  This approach is more common 
for Spice type simulations.

• Insert connector symbols that allow an external signal generator to provide input

I inserted CONN_1 components from the 'conn' library so that the top level schematic looks like the 
following.  Note that if the rules checker complains that input signal pins are not being driven, then use 
the symbol editor to open the 'conn' library and edit the CONN_1 symbol.  The pin direction should be 
'Passive'.  It may be enough to simply save the pin and update the library, to satisfy the rules checker.

Top level schematic with a single adder sheet

Producing a Component Symbol

No connect symbol


