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The Dreamweaver Interface
Let’s take a moment to discuss the different areas of the Dreamweaver screen.

The Document Window

The Document Window shows you the current document. This is where you are going to create
your web pages (i.e. create page layout, add text, images, and hyperlinks).

mny VE&EE-4-DQ|D-P

Untitled-1*
\+2| Code ’;ﬁjSplit ’ | Design | Title: | Untitled Document < ,Lv’f .  C E

This 15 the document window.

Figure: The Document Window

The Properties Inspector

Whenever an item is selected in Dreamweaver, the properties for that item appear within the
Properties Inspector. When you highlight a line of text, the Properties Inspector shows you the
font style, font size, font color, etc.

Use the following selected text as an example:

some sample highlighted text

The Properties Inspector tells us that the default font is selected for this text (Times New Roman
is the default font in Dreamweaver), no size is specified for the text, and the color of the text is
red.
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Figure: Properties of the highlighted text in the Properties Panel
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The Panel Groups

On the right side of the Dreamweaver screen, you should notice a large group of panels that are
stacked on top of each other. The Panel you will use most often within this pile is the Files
Panel. You will access this area when you are ready to send your website files via FTP to the
server.

£ P Design
£ p Code
£ p Application

i P Tag Inspector

(* Files =
Figure:%‘%f Available Panels in Dreamweaver

Page Views: Code, Design, and Design and Code (split screen)

There are three different ways to view the document window in Dreamweaver. Depending on
your skill level, you will select the view that works best for you.

Design View

2| Code ‘jSplit
ommen v RE&(EE-4-BQB-E

Design view shows your
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format. This view is the
best view for beginners.

This 15 the document window.

Figure: Design view

Code View
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a PE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"

A “http: //vww. w3, org/TR/htunld/loose. dtd™>

< <html>

Y <head>

L <title>Untitled Document</titles

) <meta http-equiv="Content-Type” content="text/html; charset=is0-8859-1">

8 < /head>

g

N <hody>

i} This is the document window.

18N < /body>

il < /html>
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Figure: Code View
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Design and Code View
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6

the bottom. b < /head>
8
a

<body>
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This 1s the document window:.

Figure: Design and Code View
FTP and the Files Panel in Dreamweaver

Why does Dreamweaver “Define Sites”’?

In order to get you accustomed to the idea of keeping your website files in one place on your
computer, Dreamweaver asks you to “Define Sites”. In other words, Dreamweaver wants you to
tell it where you are going to store your website files on your computer (referred to as ‘local’
storage) so that you can upload them from this location to the server later (referred to as ‘remote’
storage.

Note: If you have multiple websites, then you will have to define a site in Dreamweaver for
each of those sites.

“Putting” and “Getting” in Dreamweaver

FTP is a built-in feature in Dreamweaver, but Dreamweaver uses its own terms for copying files
from and sending files to the server.

* Put — take your local files and put them onto the remote server.

* Get — get files from the remote server and place copies of them onto your computer.

Defining a Site
Through the use of the Files Panel, you will provide a “definition” for your website (i.e. the
location of your website and its files on your computer).
To Define a Site, do the following:
1. Double click onto the Files Panel to open it. Click onto the “File” tab.
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© ¥Files =
Files

(@ Desktop v Citanage Sites D

Figure: Opening the Files Panel and Selecting the Manage Sites link

a. Notice the first drop down menu within the Site tab (circled above).
1. The Manage Sites link will allow you to select a defined site.
ii. Click onto the “Manage Sites” link to define your website (see above
image).
iii. Note: You can also define new sites through the Dreamweaver toolbar.
To do this, select Sites = Manage Sites.

2. You will now fill in a series of screens to “Define Your Site”.
a. Site Definition

1. This will be the name of your website in Dreamweaver. A name such as
“My Website” is fine, but keep in mind if you have multiple websites,
your site names should be more specific.

it. Click “Next”
b. Do you want to use server technology such as Cold Fusion, ASP.NET, ASP,
JSP or PHP?
1. Select “No, I do not want to use server technology”
it. Click “Next”
¢. How do you want to work with your files during development?

1. Select “Edit local copies on my machine, and then upload to server when

ready (recommended)”
it. Click “Next”
d. Where do you want your computer to store your files?

1. This is where you will designate the location of your website on your
computer. Browse your computer and create a folder in the location you
specify. Give this folder the same name as your website.

it. Click “Next”
e. How do you connect to your remote server?

1. From the drop down list, select “FTP”

ii. For the hostname, enter “facftp.hartford.edu” (students would enter
uhaweb.hartford.edu)
iii. Leave the “What folder do you want to store your files in on the server?”
portion blank
iv. For “What is your FTP Login”, enter your email username
v. For “What is your FTP Password?”, enter your email password
vi. Select “Test Connection” to make sure that your login information is
correct
vii. If you information is correct, select “Next” otherwise re-enter your Login
and password information until correct
f. Do you want to enable the checkin/checkout option?
1. Select “No”
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it. Click “Next”
g. Click “Done” to finish.

Sites Tab Options

In the Sites tab, you have a list of your defined sites in the left drop-down menu, and in the right
drop-down menu, you have the “view” of your website. These two views are either Local (on
your machine) or Remote (on the server).

When you work on your website, you must be in Local view. At this point, there are no files
within your website locally (remember, locally means on your computer), so the list should
appear empty as it does in the Figure below:

i ¥ Files =
Files

Ii_j Learn Dreamweave ¥ | Local view v
2C|dHYa|E

(3 site - Learn Dreamweaver (C:\Documen

Figure: The Site Tab Options

From the Site Tab in the Files panel, you can take the following actions (see numbered items in
image above):

1. Connect — connect to the server. This is literally an image of an electric plug. To
connect to the server, click onto the Plug icon to “plug-in”.

2. Refresh — When you are connected to the server, you can “refresh” your view of the files
available on the server. You should use “Remote View” when using this option.

3. Get — To use this option, you must first connect to the server, and select the “Remote”
view option. Once you are connected, you can get copies of all the files from the server
or select the files you want to copy. To select files, click once onto the file name and
then click the “Get” button. To select more than one file, hold down the Shift key, and
then click once onto the file.

4. Put— To use this option, you must first connect to the server. You will use Local view
for this option. This is where you will put files from your local site up onto the server.
To put your entire site on the server, just select the “Put” arrow. To put an individual file
on the server, select the file by clicking onto it once, and then click the “Put” arrow.

5. Check Out — Click onto a filename once to highlight it, and then select the Check Out
option. You will have checked out that file so that no one else can modify it. You will
use Local View for this option.

6. Check In — Click onto the filename that you have checked out, and then select the Check
In option. You will make the file available for others to use and modify. You will use
Local view for this option.

7. Expand Collapse — If you select this button, you will expand the Sites tab, and it will
occupy the entire screen. Select this option only if you want a larger view of the Sites
tab.
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Creating Pages in Dreamweaver

Note: When you open Dreamweaver, it may by default have a blank webpage open and
ready for you to use. If not, follow the instructions below.

To create a New Page in Dreamweaver, do the following:

* Click onto File = New Document
New in the General | Templates
Dreamweaver Category: Basic page: Preview:

menu. <q ~Hasic page @ HTML
. -ByRamicpage @

Choose “Basic : R
emplate page @ Library item
Page” and “HTML” Other @ ActionScript
° : 13 i) (S5 Style Sheets @ €55
Cth onto Create Framesets @ JavaScript <No preview>
to open the page. Page Designs (C55) @ ML

Page Designs
Page Designs (Accessible)

Description:
HTML document

[[Imake document HTML compliant

[ Help J [ Preferences... J Get more content. .. ( Create ; Cancel

~—————

Figure: Adding a New Page in Dreamweaver
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Creating Page Layout Using Tables

One of the easiest ways to create page layout is to use a table. The following diagram shows you
basic page layout created through the use of a table:

Page Title
Navigation Bar
Content Area

=

Page Footer

\4)

If you add table and merge some of the cells, you can easily create the layout pictured above.

Inserting a Table

1. Select Insert = Table from the Dreamweaver menu
2. Specify the number of rows and columns

a. Enter “2” for rows and columns
b. Width =75 percent
c. Border = 0; this means that no table lines will appear when you view your website
inside the browser.
d. Click “OK”
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Table
Table size
Rows: ‘2 \ Columns: l'Z
Table width: iéli \ ;percent v 1
Border thickness: :U \ pixels
Cell padding: \ EE
Cell spacing: %
Header
’ - | - ‘ TR
- EEE -
- [ o f oo | -
- ’ e -
Left Top Both
Accessibility
Caption: \
Align caption: (default b
Summary:
o ) (oo ]

Figure: Inserting a Table in Dreamweaver and Specifying Table Properties

3. You now have a table that looks as follows:

(==
|

NE & E

Common ¥

Untitled-1*

E-4-8QB-F

H 2| Code |j Spit | 3| Design | Title: Untitled Document

Figure: Table inserted into Dreamweaver

4. There are some things to note about this table:
a. The table is selected by default.

b. It’s properties appear in the Properties Panel:
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i v Properties

,’::I Table 1d Rows 2 W |75 %o v CellPad Align | Default v | Class | None v
rr-
v Cols |2 H pixels | CellSpace Border |0
e e e Bg colorg Brdr color g
a Ir 1% Bg Image & D

Figure: Properties of the inserted table

c. You can see the number of rows and columns specified when you created the
table including the the default width (set to 75%), and the border set to 0.
5. Deselect the table (click off of it to deselect it)
6. Click inside any one of the table cells. We will now format the table.
a. Inside the circled item (see image below), there are two options: merge cells (on
the right) and split cells (on the left)
b. Merge cells allows you to combine two cells
c. Split cells allows you to select a cell and divide it into more than one cell

' ¥ Properties
Format | None v | Style | None vl BI E Link v D
Font | DefaultFont v | Size| M v Q IZ iZ 45 2E Target
=l g Horz Default + | W Nowrap [] Bg 7 (i Page Properties...
r—r—l
@ ert |Default v H Header (] Bg Q Brdr Q

Figure: The “Merge” and “Split” cells option

7. In order to begin merging and splitting cells, you must highlight the cells you want to
merge. This will take practice.

8. Select the top two cells in the table. Merge these two cells by clicking onto the merge
cells button in the Properties Panel.

ommn v REDE|BE-4-B QB

Untitled-1*
| 4| Code \j Split l | Design | Title: Untitled Document T I @. | ¢ B

% ’
t 579 (572) v

Figure: Selecting and then Merging Two Table Cells

Y our table should now look like as follows:
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Figure: Result of Merging Tables

9. Go to the second row of the table and locate the column line (see item circled above).

10. Place your mouse over this column line until you see the cursor turn into two horizontal
arrows. When you see these arrows appear, you are able to drag the line either left or
right.

11. Drag the column line over to the left leaving approximately 4 column width on the left
and ¥ column width on the right (see below).

oy WD S|AE-4-BQD-F

Untitled-1*
Lol code | =5 spit | 9] Design | il [Unttled Dcument Y8 @ CE

Figure: Sliding Column Line Over to Create Larger Right Cell and Smaller Left Cell

12. Click into the bottom right cell (as circled above) and hit the Enter key 5 times.
13. Your table should now look as follows:
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Common ¥ RELE
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Untitled-1*

.................................................................................................................................................

Figure: Increased Height of the Right-Bottom Cell

Looking at the above picture, you can see a page layout somewhat similar to the one presented in
the beginning of this section.

14. Click into the top cell in the table, and hit Enter one time. Your table should now look as
follows:

Common ¥ Q = &

FE-4-BRIB-&

Untitled-1*

’ Us_;l Code lESpIit | 4| Desian | Title: | Untitled Document | 80 @. ’ c E.

S o Fei s 75%(424)'i
! 57% (572) v 1
Figure: Finished Table Layout
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Adjusting Cell Alignment

Before you can begin adding text and images to your webpage, you will need to adjust the table
cell properties.

Note: Adjust cell properties. You will not be able to position your cursor properly within the
table cell otherwise.

* Click into each cell in your table. You will adjust the settings for each cell one by one.

Click into the cell that represents the area where you will place your navigation.

* The properties for that cell appear in the Properties Panel.

*  When you click into this cell you will not that the cursor appears in the center of the cell.
However, you need to have this cursor appear at the top.

Common ¥ @E&‘@@v®.@‘,@

Untitled-1*

| 52| Code ‘:,:] split ‘ (] Design | Title: | Untitled Document e | E

Chck herel

—— 259 (137) v 7596 (424) v

579% (572) v

Figure: Clicking into the navigation cell

* Find the vertical alignment properties. Adjust them so that the vertical alignment is set to
“Top”. See image below:

. ¥ Properties
Format | Mone [octat o) M BZ E=E==E |k v 3D
Default Font Top 5=
Font | Default Fonl vMiddIe D = 3= &= 2= Target
;:I cell orz gg;ﬁi‘:e 5% | Mowrap [ ] Bg DD
[ | rt |REENE v | H/190 Header [ | Ba EI Brdr g
~—" Figure: Properties of the Selected Cell

* Repeat these steps for each cell in your table. If you are not sure whether to adjust the
vertical alignment properties, click into a cell and see where the cursor is placed by

default. If it is not at the top where you would like it to be, then adjust the properties for
that cell.
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Note: You will not have to adjust the properties for the content cell (i.e. the large cell on the
right where the text for your web page will be located). Since you clicked into that cell
previously and hit the Enter key 5 times, the cursor will appear at the bottom of the cell. Use the
“1”" arrow on the keyboard to bring the cursor back up to the top of the cell.

Adding a Navigation Bar to your Page Layout
One of the easiest ways to create a navigation bar is to insert another table into the cell you have
specified as the navigation area of your webpage.

To add a navigation bar using a table,

Click into the cell you are using for navigation. Be sure that you have already adjusted
the vertical spacing for this cell. If not, refer to the previous section.

Go to “Insert = Table” to insert a table.

Choose to insert a table with 1 column and 3 rows (the number of rows depends on the
number of areas in your site). Set the table border equal to 0. Leave the table width as
75%.

You can now type the name of each section of your website within these cells. For
example,

Home
Courses
Contact

These names represent the areas of your website. Each of these areas in turn (particularly
Courses and Contact) may have different subsections. When you create the navigation
areas on these other pages, you will need to remember to add extra rows in the table to
represent these sub areas. For example, here is what the navigation bar might look like
for the “Courses” page.

Home
Courses
ENG 110
ENG 355
Contact

Note the “ENG 110” and “ENG 355 are indented within the table. This is a visual cue
that indicates where these two pages are in relation to your entire site. Remember to
follow this convention so that users of your site will understand how your site is
organized.
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Text, Images, and Hyperlinks
Adding Text

Entering text into Dreamweaver works similarly to the typing text into Word documents.
A few notes on adding text into your web page:

* Paragraphs are automatically double spaced

o For single spaced paragraphs, hold the Shift key and then press Enter
* Selecting Fonts and Font Sizes

o Through the use of the Properties Panel, you can highlight some typed text, and
then select the font style from the drop down list:

i v Properties

Format | None v | Style | None v

e B T

-]
~N

Link v 3D
Target

Page Properties...

[
[

Figure: Use the drop-down menu in the Properties Panel to change text font and font size

o From the Dreamweaver toolbar, you can also select “Text” tab; a menu of text
options will open, and these will also allow you to change text size, color, font,

and check spelling.
Images

To insert an image into Dreamweaver, select Insert - Image
Browse your computer for the desired image
Click “OK” to save your changes

After you insert your image, select it (i.e. click onto it once)

omn > WES|EE - 4-BR|D-F

Untitled-1*

\«?| Code ’jSplit 1 | Design | Title: |Untitled Document od 4 @. | ¢ B

Figure: Inserting an Image into Dreamweaver and Selecting It
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The properties for your image now appear in the Properties Panel. The Panel displays the
following information:
e SRC - this is the image source which is the location on your computer of the image file
o Ifyou wanted to delete the image and insert another one in its place, select the file
folder located next to the name of the image (see image below)
* W and H — this is the width and height of the inserted image

¥ Properties

Image, 4K W 416 Src | ed Site l,flogo_topz‘giAIt

v Class | None v
H[71 Link GO et @9 NE O A
Map ¥ Space Target Border £E £ =
A OOV H Space Low Src €y ) Align |Default v

Figure: Properties of a Selected Image in Dreamweaver

Adding Hyperlinks in Dreamweaver

Before we discuss how to add hyperlinks in Dreamweaver, it is important to explain the different
kinds of hyperlinks that you can create in a website.

The different types of hyperlinks are as follows:

¢ External link: A link to a web page outside of your web site. An “off site” link. This
type of link requires an absolute URL (i.e. you must type in the full address
“http://www.hartford.edu”). Did you know? You can also make links to Word
documents, PowerPoint files, Excel spreadsheets, PDF documents or any other computer
file as long as it has been uploaded to your website.

* Internal link: A link to another page within your site. Internal links should use relative
URL’s. A relative URL refers to an HTML document on the same machine as the
current document'. Dreamweaver will create relative URL’s by default. More about
these later.

* Email link: Specify an email address for users to send email; will open the users email
program and fill in the “To:” portion with the address you specified”

To Add an External Link

1. Select the item

2. Go to the Properties Panel and find the “Link” text box

3. Type in the full address of the website you want to create a link to (i.e.
http://www.hartford.edu)

To Add an Internal Link
1. Select the item
2. Go to the Properties Panel and find the “Link” text box
3. To the right of the text box, find the folder icon

"HTML and URL’s. (2003). World Wide Web Consortium. Available: http://www.w3.org/TR/WD-htm140-
970708/htmlweb.html.

? Dreamweaver Intro — Part 1: Web Site Basics. (2003). OIT Academic Computing. Lederle Graduate Research.
University of Massachusetts Amherst.
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4. Click onto the folder icon to Browse the your website for the page you want to link to.
5. Link to other HTML pages within your website or link to other files that you have
uploaded (Word documents, PDF documents, PowerPoint files, etc.).

To Add an Email Link
1. Select the item
2. Go to the Properties Panel and find the “Link” text box
3. In the Link text box, type “mailto:theemailaddress”
a. So, if you wanted the email to come to the FCLD, the link would be
mailto:fcld@hartford.edu

Publishing Your Website

Note: Before you can begin with these instructions, be sure to define your site within
Dreamweaver. See the “Defining a Site” section of this handout for more information.

Once you are done creating your website, the next step is to upload it to the web using FTP.
When you defined your site, you specified FTP information such as your login ID and password.

In order to connect to your site, do the following:

—

From the Files Panel, be sure that the Sites tab is selected.

Click onto the “Connect” icon to connect to your remote server. This icon is literally an

image of an electric plug. When you are connected, this icon will appear “plugged-in”.

3. By default when you connect to your website, you are switched to Remote View because
now you are viewing files on the server.

a. Note: If this is your first time uploading files to your website, then the list of
available files should be empty with the exception of a few folders that are placed
there by the server administrator.

4. Switch from Remote View to Local View. You will now select the files you want to send
to the server. If this is the first time that you have uploaded files to the server, select the
root folder of your website to send all files. . Select this folder by clicking onto it at
once. Otherwise, simply click once onto the files you want to send to the server.

N

i ¥ Files =

Files

D Website Vv | Local view v
AR K

=TT Site - FCLD Website (5:\FCLD_
Figure: Selecting the “root” folder of your website

5. Select the “Put” arrow to send your files to the server. See image above.
6. Your files are now available online.
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Getting your Website Files from the Server for Editing

Do you already have a website, but this website needs updating? You can use Dreamweaver to
“get” your website files from the server to edit on your own computer.

Before you can begin the using the instructions provided here, you must follow the directions for
“Defining a Site” on page 8.

1. Click onto the “Connect” icon to connect to your remote server. This icon is literally an
image of an electric plug. When you are connected, this icon will appear “plugged-in”.

2. By default when you connect to your website, you are switched to Remote View because

now you are viewing files on the server.

Select the root folder of your website from Remote View.

4. Select the “Get” arrow to get copies of the files from the server placed onto your
machine.

5. You have now downloaded all of your files. Edit and save them as needed.

[98)

Maintaining Your Site: Dreamweaver Templates

Templates are useful tools in that they ensure a consistent “look and feel” for your website.
Every time you create a new page for your website, that page will automatically be based upon
pre-established guidelines. In addition, Dreamweaver templates are smart — once updated, they
will automatically update any files associated with them. This means that you spend less time
maintaining your website.

Step One: Create a Template File
In the Dreamweaver menu, do as follows:
1. Select File > New
2. A small dialog opens. Click onto the General tab
3. Select Template > HTML Template Page
4. Click “Create” to create the page (see image below)
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New Document

General | Templates
Category: Template page: Preview:
Basic page 2 ASP JavaScript template
Dynamic page 2  ASP VBScript template
- Template page 2 ASP.MET C# template
Other 2 ASP.MET VB template
(55 Style Sheets 2 ColdFusion template
Framesets 2 HTML template <No preview>
Page Designs {CS5) 2 JSPtemplate
Page Designs 2 PHP template
Page Designs {Accessible)
Description:
Dreamweaver ASP JavaScript template
document
[[IMake document XHTML compliant
[ Help ] [ Preferences... ] Get more content... [ Create ] [ Cancel ]

Figure: Creating a Dreamweaver Template File.

Step Two: Create your Desired Page Layout Using a Table

Refer to pages 7-12 for more information about creating page layout using tables.

Step Three: Create “Editable” Regions

Your next step is to create editable regions within your template — areas on your webpage that
are going to change from page to page. The best example of an editable region is the content
area of the page. While the navigation bar will not change, the content of each page will.

To add an editable region, click into the table cell that represents an area that will change (i.e.
click into a cell reserved for page content).
1. Select Insert > Template Objects > Editable Region
2. When you insert an editable region, you will be asked to give that region a name. Some
templates have more than one editable region, which is why you are asked to name yours.
3. Name this region “Content”.

Step Four: Save Your Template
To save your template, select File > Save

Creating a Page from a Dreamweaver Template
To create a new page from a template, do as follows:
1. Select File > New

2. The small window opens with two tabs: General and Templates. Select the Templates
tab.
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3. A list of all your currently defined websites will appear. Select the name of the website
that you want the template from, and then select the name of the template.

4. Click “Create” to finish.

5. You can now create a new page from the specified template. Remember that you can
only alter the sections of the page marked as “Editable.”

Updating a Template

To update a template, do as follows:

1. Within the Files Panel, look at the files within your website.
Find the “Templates” folder.
Open the desired template by double clicking onto it.
Make your desired changes.
Save the file. You will be asked to update all the pages associated with the template.
Select “Yes” to update all the files. Dreamweaver will then show you a status window
displaying the number of files it is updating and which of those files were successfully
updated.

Nk

Instructional Technology at the University of Hartford

Faculty Center for Learning Development

FCLD provides consulting and support to faculty interested in incorporating technology into instruction.
Telephone: 768-4661

Email: fcld@hartford.edu Website: http://uhaweb.hartford.edu/fcld

Information Technology Services:

ITS Help Desk

Contact the ITS Help Desk for general computer and Internet/network support questions ITS Help Desk
(technology not directly related to the classroom but rather passwords, Internet/email problems, printer
not working, banner, facebook, grades).

Telephone: 768-5999

Email: its@hartford.edu Website: http://uhaweb.hartford.edu/its/

Media Technology Services

MTS is a department devoted to fulfilling equipment requests and the integration of technology into
classes. Faculty may request additional equipment to be delivered to classroom.

Telephone: Main 768-4643

Email: mts@hartford.edu Website: www.hartford.edu/mts
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